Inability to Edit Campaigns and Line Items
Incident Report for Beeswax
Resolved
This incident has been resolved.

We apologize for any inconvenience this may have caused.
Posted Oct 14, 2020 - 16:42 EDT
Monitoring
We have identified and resolved an issue that prevented users from saving objects within Buzz. We are monitoring the fix to ensure that everything is working as expected.

We apologize for any inconvenience.
Posted Oct 14, 2020 - 15:44 EDT
This incident affected: Buzz UI and API.