Global Internet Disruptions: Bidding Disabled from 3:25 PM EST Until Stability Returns

Incident Report for Beeswax

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 16:04 EDT

Update

Bidding was restored at 3:50 PM, as the 3rd party entity involved in the outages resolved the issue.
Posted Jun 12, 2025 - 16:03 EDT

Monitoring

In order to protect the client experience, the Beeswax Engineering team has elected to stop bidding until the Global Internet outages are resolved. There is a risk that a full lifecycle of bid related traffic, potentially affecting financial outcomes, could not reach our endpoints or those of our clients. Bidding was turned down at 3:25PM EST, but minor effects of the global situation had been noticed in the leading in period.

Details about the outage can be found at: https://www.thestreet.com/crypto/markets/massive-cloudflare-outage-takes-down-major-apps-google-discord-spotify-hit
Posted Jun 12, 2025 - 15:36 EDT
This incident affected: Bidding (Bidding - US East, Bidding - US West, Bidding - EU West, Bidding - AP Northeast).