Duplication Error with Creatives

Incident Report for Beeswax

Resolved

This incident has been resolved. Thank you for your patience.
Posted May 14, 2025 - 17:19 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 14, 2025 - 13:19 EDT

Investigating

We are aware of and investigating an issue related to Creatives not being able to duplicate. We are actively working to address the issue and will provide updates as available
Posted May 14, 2025 - 11:29 EDT
This incident affected: Buzz UI and API.