Intermittent UI Slowness
Incident Report for Beeswax
Resolved
This incident has been resolved.
Posted Feb 23, 2024 - 12:53 EST
Update
Delivery Status in Line Item List View has resumed normal functionality.

Latency is greatly reduced for all endpoints, though optimizations are ongoing and customers may experience intermittent latency until work is finalized. Further updates will be shared as available.
Posted Feb 08, 2024 - 16:59 EST
Update
The majority of List Views objects have resumed normal performance. Advertiser and Campaign List Views may still present up to 30 second delays for some users, but are loading without errors.

Please note, as part of our ongoing investigation and optimization, Delivery Status in Line Item List View is temporarily not being updated in near-real-time. Please instead refer to real-time Bid/Win stats in the Line Item object.
Posted Feb 06, 2024 - 19:15 EST
Update
We are continuing to optimize for a customers experiencing latency with the list view for line items, advertisers, deals and segment uploads, and campaigns (all UI only), particularly for customers with exceptionally high number of line items. Latency and error rates are decreasing, but optimizations are ongoing.

Further updates will be shared as available.
Posted Feb 06, 2024 - 11:38 EST
Identified
We are aware of and investigating UI slowness and intermittent load errors for the UI. Currently we believe impact to be limited to Line Item List View, Custom List, and Segment Upload List View endpoints (UI only); but we will confirm via further investigation. Updates will be shared as available.

No other functionality other than visibility/loading of these endpoints in UI is impacted.
Posted Feb 05, 2024 - 16:57 EST
This incident affected: Buzz UI and API.