Creative Upload Issues

Incident Report for Beeswax

Resolved

This incident has been resolved
Posted Jul 15, 2025 - 14:10 EDT

Investigating

We are currently experiencing an issue with creative uploads and transcoding. Our team is working to resolve as soon as soon as possible.
Posted Jul 15, 2025 - 10:57 EDT
This incident affected: Buzz UI and API.