Snowflake Incident: Impacting Bid Decision Flow, Delayed Reporting & Delayed hourly Win Logs

Incident Report for Beeswax

Resolved

The Snowflake (AWS) service impact has been resolved, and services are either recovering or fully recovered. Network operations is monitoring. Please direct any follow-up questions to your account representative.
Posted Mar 19, 2025 - 17:23 EDT

Identified

We have identified an issue with Snowflake, causing Bid Decision Flow display issues and delayed reporting including hourly win logs. We will update you shortly. Thank you for your patience
Posted Mar 19, 2025 - 14:50 EDT
This incident affected: Reporting (Reporting - US East, Reporting - US West, Reporting - EU West, Reporting - AP Northeast).